throw new TypeError(‘Invalid Version: ‘ + version);

2019-11-17 8:41:52 250 views

throw new TypeError('Invalid Version: ' + version);

环境:

windows10

npm 6.13.0

node:12.13.0

vue-cli3.x

问题描述

vue项目运行npm run serve的时候跑不起来,报错throw new TypeError('Invalid Version: ' + version);

解决方案

1.如果有package-lock.json的话去除/package-lock.json 。但这个对我没有效果

https://github.com/npm/npm/issues/7506

2.清除缓存

    yarn cache clean   或者 npm cache clean --force  
具体原理可以参考
 https://juejin.im/post/5c77e05e518825407a32b94b 
0

No Comments

发表评论

电子邮件地址不会被公开。 必填项已用*标注

分享到微信朋友圈

打开微信,点击底部的“发现”,
使用“扫一扫”即可将网页分享至朋友圈。